Ok, so I have a really weird data leak and I need help with it, as it seems I am not getting any help from AT&T or Apple. AT&T can’t tell me where my data is going, and Apple hasn’t heard of this issue as of yet, which I guess is fine, since it is only a 10 day old issue. I’ll see if anyone else has this and can help, or maybe an Apple Rep can help.

Lost yet? I’ll give you the background. I have had an iPhone 4 (GSM) on iOS 4.1 for the longest time because of the jailbreaks not being untethered until recently. I don’t upgrade my phones software unless the jailbreak is untethered and confirmed for Windows (either redsn0w or greenp0ison). I saw this tweet from the iPhone Dev Team saying that iOS 4.3.1 was jailbroken untethered, and jumped in! I skipped iOS 4.2, 4.2.1 & 4.3 because of jailbreaks that were tethered, and were lost once you rebooted the phone. Well let’s just say EVERYTHING was fine and dandy on 4.1.. but then I upgraded to 4.3.1.

For the Find my iPhone that was added in 4.2, and the personal hotspot that was added in 4.3.

So I updated and started having issues. With my themes, the background for the Lock Screen and Home Screen had gone missing in my themes. When I tried to apply a different theme, I kept getting a black background with a square and blue question mark. So it looked like from 4.1 to 4.3.1, Apple has changed the location of the home screen and lock screen wallpaper locations. No problem, I just moved the wallpaper to the locations that the themes were looking for them, instead of trying to find where Apple had moved the new ones, or possibly renamed them, to make them harder to fine. Stupid Apple.

Ok, so I kind of did a work around to make my theme work, but I used to be able to change my background in the settings on the phone, now I will have to use iFile or SSH into the phone from my laptop to change my wallpaper. Stupid Apple.

Then I came across this little gem today… My iPhone is apparently sending CRAP loads of data either late late at night or early in the morning, at the cost of 300+MB a pop! It’s a good thing I have the “Unlimited” 5GB of data. So let’s start a timeline here so you get an idea where I am going with this.

April 4th 2011 – roughly around 10:30PM I backup 4.1, before I update to 4.3.1 as you see below.

Just for reference I started my new career as a Tier 1 Tech Support on Tuesday 4/5/11 the next morning at 8am.

So the first full week goes by of me being at my job, and we finally got desks, workstations and laptops on Friday 4/8/11.

Then yesterday, Wednesday the 13th, for the first time in a long time, I booted up Pandora (over 3G) just after getting to work at 8am. I let it run pretty much all day, except for my 1 hour lunch break and left to go home at 5pm. So we can say roughly 8 hours out of the day, I ran Pandora. Then today (4/14) I did the same, booted up Pandora and for say maybe 7 hours of the day, because I paused it a lot more because of meetings and conversations I was having in the office. So we have a total of 15 hours of Pandora being used in a two day period. That’s it.(They have a 40 hour cutoff for free accounts)

So I went to check my usage on my account since I have a 5GB cap. Wow was I surprised! I went to investigate and found a few little instances where my Phone was spitting out some serious amounts of data, and at times I wasn’t even awake!! The worst part, is that it was doing it over 3G and not my wireless connection. So let’s see those “issues”:

See that? What happened here? I have a lot of data being used across my phone. And I don’t know how either. So I looked into it, and it seems that I have had over 2.5GB used in the past 10 days, which is what the at&t account page lets me see. So let me put this in a table like view, so it’s all grouped together.

364,139KB (355.6MB) 04/05/11 11:47pm (im in bed asleep by 10 or 10:30pm)
322,353KB (314.8MB) 04/06/11 11:12pm (asleep)
138,392KB (135.15MB) 04/10/11 07:46pm (I was up, but watching netflix on my xbox)
359,160KB (350.74MB) 04/10/11 11:13pm (asleep, but later that night)
448,801KB (438.28MB) 04/11/11 10:56pm (asleep, the next day)
675,764KB (659.93MB) 04/13/11 06:49am (i don’t wake up till 7am)

The thing that gets me, is this is all since I update to 4.3.1 on the 4th. Now I think someone will say that it is because I have a jailbroken phone, but you can’t say that, because I have had a jailbroken phone since iPhone 2G. I always jailbreak them. I also noticed that I was having battery issues as well, and my battery was getting worse than before. See below:

So then I thought, let’s go back to the previous months to see what my data use was. AT&T has a data calculator to show you what you have used historically so you can make decisions on changing packages. So let’s see what that looks like.

Wow. Nowhere close. Except for Christmas, because I was out of town and using tethering on my iPhone for my laptop when I couldn’t get a good landline cable or DSL connection. Nothing over .5GB at all. That seems to be my normal usage (skipping December) for the last 6 months, well 5. So you see what I mean? I think I need to go back to 4.1. The only problem is, I will lose Photoshop Express because they quit supporting 4.1 and I can’t have the latest version of the app if I go back. Boo..

I need help. Any others with this problem? Can you help? Leave comments below or check out the two threads I have joined on the Apple forums.

4.3.1 bug by Judyabro

or the one I started (with the exact same question)

Magical Overnight Data Uploads or just plainly data loss

I’ll link back to this page as well.